Problema
Ao tenta baixar um arquivo pelo Latromi Web, seja através de um link comum ou através do Extrator de Arquivos o download inicia mas é imediatamente cancelado, exibindo a mensagem no navegador:
Falha - Nenhum arquivo
Causa
A causa mais provável é que o Tipo MIME (Mime-Type) do arquivo não está sendo enviado no cabeçalho da resposta do servidor. Isso acontece quando a extensão do arquivo não possui um Tipo MIME vinculado no IIS.
Solução
A solução para este problema é registrar o Tipo MIME do arquivo no IIS.
Para fazer o registro, siga os passos abaixo:
- Abra o IIS
- Selecione o servidor.
- Abra o cadastro de Tipos de MIME.
- Clique na opção “Adicionar” para adicionar um novo Tipo MIME.
- Cadastre a extensão do arquivo e o Tipo MIME correspondente